using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?:\s*\* \N+\n)+)";
string input = @" * Some text in a bullet list.
* Some more text in the same bullet list
Break my pattern with a random number of normal text.
That keeps going for some time
* Back to some text in a bullet list
* That goes on
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}