package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(?:\s*\* \N+\n)+)`)
var str = ` * Some text in a bullet list.
* Some more text in the same bullet list
Break my pattern with a random number of normal text.
That keeps going for some time
* Back to some text in a bullet list
* That goes on
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}