import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:\\s*\\* \\N+\\n)+)";
final String string = " * Some text in a bullet list.\n"
+ " * Some more text in the same bullet list\n\n"
+ "Break my pattern with a random number of normal text.\n"
+ "That keeps going for some time\n\n"
+ " * Back to some text in a bullet list\n"
+ " * That goes on\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}