import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|(?<=\\[)[^\\[\\]]*(?<nested>\\[[^\\[\\]]+\\])[^\\[\\]]*|(?<=(?!\\A)\\G)(\\[[^\\[\\]]*\\])[^\\[\\]]*(?=(?:[^\\[\\]]*\\[[^\\[\\]]+\\])*\\])|(?<=(?!\\A)\\G)[^\\[\\]]*(\\[[^\\[\\]+]\\])[^\\[\\]]*(?=\\]))|(?<simple>\\[[^\\[\\]]+\\])";
final String string = "[e],[a] b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e and] and [d]] followed by [f] then [g][h]d[f]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}