const regex = /(?|(?<=\[)[^\[\]]*(?<nested>\[[^\[\]]+\])[^\[\]]*|(?<=(?!\A)\G)(\[[^\[\]]*\])[^\[\]]*(?=(?:[^\[\]]*\[[^\[\]]+\])*\])|(?<=(?!\A)\G)[^\[\]]*(\[[^\[\]+]\])[^\[\]]*(?=\]))|(?<simple>\[[^\[\]]+\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(?<=\\[)[^\\[\\]]*(?<nested>\\[[^\\[\\]]+\\])[^\\[\\]]*|(?<=(?!\\A)\\G)(\\[[^\\[\\]]*\\])[^\\[\\]]*(?=(?:[^\\[\\]]*\\[[^\\[\\]]+\\])*\\])|(?<=(?!\\A)\\G)[^\\[\\]]*(\\[[^\\[\\]+]\\])[^\\[\\]]*(?=\\]))|(?<simple>\\[[^\\[\\]]+\\])', 'g')
const str = `[e],[a] b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e and] and [d]] followed by [f] then [g][h]d[f]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}