import re
regex = re.compile(r"(?|(?<=\[)[^\[\]]*(?<nested>\[[^\[\]]+\])[^\[\]]*|(?<=(?!\A)\G)(\[[^\[\]]*\])[^\[\]]*(?=(?:[^\[\]]*\[[^\[\]]+\])*\])|(?<=(?!\A)\G)[^\[\]]*(\[[^\[\]+]\])[^\[\]]*(?=\]))|(?<simple>\[[^\[\]]+\])")
test_str = "[e],[a] b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e and] and [d]] followed by [f] then [g][h]d[f]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")