re = /(?|(?<=\[)[^\[\]]*(?<nested>\[[^\[\]]+\])[^\[\]]*|(?<=(?!\A)\G)(\[[^\[\]]*\])[^\[\]]*(?=(?:[^\[\]]*\[[^\[\]]+\])*\])|(?<=(?!\A)\G)[^\[\]]*(\[[^\[\]+]\])[^\[\]]*(?=\]))|(?<simple>\[[^\[\]]+\])/
str = '[e],[a] b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e]] followed by [f] then [g] a b [[c], [d] then [e and] and [d]] followed by [f] then [g][h]d[f]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end