#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+\D*?)\s*(\d+)|(\S.*)"
Local $sString = "Schblaum 12324 tunguska 24 234n" & @CRLF & _
"jacarta 331 matchika 22 234k" & @CRLF & _
"3239 thingolee 80394 234k" & @CRLF & _
"jacarta 3342"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")