// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\S+\D*?)\s*(\d+)|(\S.*)").unwrap();
let string = "Schblaum 12324 tunguska 24 234n
jacarta 331 matchika 22 234k
3239 thingolee 80394 234k
jacarta 3342";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}