import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+\\D*?)\\s*(\\d+)|(\\S.*)";
final String string = "Schblaum 12324 tunguska 24 234n\n"
+ "jacarta 331 matchika 22 234k\n"
+ "3239 thingolee 80394 234k\n"
+ "jacarta 3342";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}