import re
regex = re.compile(r"^(\S+\D*?)\s*(\d+)|(\S.*)", flags=re.MULTILINE)
test_str = ("Schblaum 12324 tunguska 24 234n\n"
"jacarta 331 matchika 22 234k\n"
"3239 thingolee 80394 234k\n"
"jacarta 3342")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")