re = /^(\S+\D*?)\s*(\d+)|(\S.*)/m
str = 'Schblaum 12324 tunguska 24 234n
jacarta 331 matchika 22 234k
3239 thingolee 80394 234k
jacarta 3342'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end