import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^CDPHP_SPRPT_GapList_[0-9]{6}(2[0-1]|1[01][0-9]|1[6-9])_[0-9]{9}.txt";
final String string = "NY_Community_CLM_DIAG_08282019.txt\n"
+ "NY_Community_CLM_DIAG_07152019.txt\n"
+ "CDPHP_SPRPT_GapList_20191028_619675879.txt\n"
+ "CDPHP_SPRPT_GapList_20191021_617641986.txt\n"
+ "CDPHP_SPRPT_GapList_20191017_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20191040_619675879.txt\n"
+ "CDPHP_SPRPT_GapList_20191018_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20191019_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20191020_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20191016_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20191015_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20191009_616743586.txt\n"
+ "CDPHP_SPRPT_GapList_20200816_616743586.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}