// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^CDPHP_SPRPT_GapList_[0-9]{6}(2[0-1]|1[01][0-9]|1[6-9])_[0-9]{9}.txt").unwrap();
let string = "NY_Community_CLM_DIAG_08282019.txt
NY_Community_CLM_DIAG_07152019.txt
CDPHP_SPRPT_GapList_20191028_619675879.txt
CDPHP_SPRPT_GapList_20191021_617641986.txt
CDPHP_SPRPT_GapList_20191017_616743586.txt
CDPHP_SPRPT_GapList_20191040_619675879.txt
CDPHP_SPRPT_GapList_20191018_616743586.txt
CDPHP_SPRPT_GapList_20191019_616743586.txt
CDPHP_SPRPT_GapList_20191020_616743586.txt
CDPHP_SPRPT_GapList_20191016_616743586.txt
CDPHP_SPRPT_GapList_20191015_616743586.txt
CDPHP_SPRPT_GapList_20191009_616743586.txt
CDPHP_SPRPT_GapList_20200816_616743586.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}