import Foundation
let pattern = #"^CDPHP_SPRPT_GapList_[0-9]{6}(2[0-1]|1[01][0-9]|1[6-9])_[0-9]{9}.txt"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NY_Community_CLM_DIAG_08282019.txt
NY_Community_CLM_DIAG_07152019.txt
CDPHP_SPRPT_GapList_20191028_619675879.txt
CDPHP_SPRPT_GapList_20191021_617641986.txt
CDPHP_SPRPT_GapList_20191017_616743586.txt
CDPHP_SPRPT_GapList_20191040_619675879.txt
CDPHP_SPRPT_GapList_20191018_616743586.txt
CDPHP_SPRPT_GapList_20191019_616743586.txt
CDPHP_SPRPT_GapList_20191020_616743586.txt
CDPHP_SPRPT_GapList_20191016_616743586.txt
CDPHP_SPRPT_GapList_20191015_616743586.txt
CDPHP_SPRPT_GapList_20191009_616743586.txt
CDPHP_SPRPT_GapList_20200816_616743586.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)