import re
regex = re.compile(r"^CDPHP_SPRPT_GapList_[0-9]{6}(2[0-1]|1[01][0-9]|1[6-9])_[0-9]{9}.txt", flags=re.MULTILINE)
test_str = ("NY_Community_CLM_DIAG_08282019.txt\n"
"NY_Community_CLM_DIAG_07152019.txt\n"
"CDPHP_SPRPT_GapList_20191028_619675879.txt\n"
"CDPHP_SPRPT_GapList_20191021_617641986.txt\n"
"CDPHP_SPRPT_GapList_20191017_616743586.txt\n"
"CDPHP_SPRPT_GapList_20191040_619675879.txt\n"
"CDPHP_SPRPT_GapList_20191018_616743586.txt\n"
"CDPHP_SPRPT_GapList_20191019_616743586.txt\n"
"CDPHP_SPRPT_GapList_20191020_616743586.txt\n"
"CDPHP_SPRPT_GapList_20191016_616743586.txt\n"
"CDPHP_SPRPT_GapList_20191015_616743586.txt\n"
"CDPHP_SPRPT_GapList_20191009_616743586.txt\n"
"CDPHP_SPRPT_GapList_20200816_616743586.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")