using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(""[^""\\]*(?:\\.[^\\""]*)*""|'[^'\\]*(?:\\.[^\\']*)*'|[^,]+),?";
string substitution = @"\1\n";
string input = @"""test"", 'test2', $test3, ?""%A %d %B %Y"", ""foo,bar,foobar""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}