import Foundation
let pattern = #"\s*("[^"\\]*(?:\\.[^\\"]*)*"|'[^'\\]*(?:\\.[^\\']*)*'|[^,]+),?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""test", 'test2', $test3, ?"%A %d %B %Y", "foo,bar,foobar""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)