package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*("[^"\\]*(?:\\.[^\\"]*)*"|'[^'\\]*(?:\\.[^\\']*)*'|[^,]+),?`)
var str = `"test", 'test2', $test3, ?"%A %d %B %Y", "foo,bar,foobar"`
var substitution = "\1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}