import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\"[^\"\\\\]*(?:\\\\.[^\\\\\"]*)*\"|'[^'\\\\]*(?:\\\\.[^\\\\']*)*'|[^,]+),?";
final String string = "\"test\", 'test2', $test3, ?\"%A %d %B %Y\", \"foo,bar,foobar\"";
final String subst = "\\1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}