const regex = /\s*("[^"\\]*(?:\\.[^\\"]*)*"|'[^'\\]*(?:\\.[^\\']*)*'|[^,]+),?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*("[^"\\\\]*(?:\\\\.[^\\\\"]*)*"|\'[^\'\\\\]*(?:\\\\.[^\\\\\']*)*\'|[^,]+),?', 'g')
const str = `"test", 'test2', \$test3, ?"%A %d %B %Y", "foo,bar,foobar"`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);