using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(A-Za-z0-9_)+";
string input = @"######## this_is_a_line.sh A-Za-z0-9_A-Za-z0-9_ ######## ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}