re = /(A-Za-z0-9_)+/
str = '######## this_is_a_line.sh A-Za-z0-9_A-Za-z0-9_ ######## '
# Print the match result
str.match(re) do |match|
puts match.to_s
end