$re = '/(A-Za-z0-9_)+/';
$str = '######## this_is_a_line.sh A-Za-z0-9_A-Za-z0-9_ ######## ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);