import Foundation
let pattern = #"(A-Za-z0-9_)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #########"######## this_is_a_line.sh A-Za-z0-9_A-Za-z0-9_ ######## "#########
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}