package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(A-Za-z0-9_)+`)
var str = `######## this_is_a_line.sh A-Za-z0-9_A-Za-z0-9_ ######## `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}