# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[((\w+)\s?)*\]/[$1]/g;t' <<< "[bad column name]"