const regex = /\[((\w+)\s?)*\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[((\\w+)\\s?)*\\]', 'g')
const str = `[bad column name]`;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);