using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[((\w+)\s?)*\]";
string substitution = @"[$1]";
string input = @"[bad column name]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}