package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[((\w+)\s?)*\]`)
var str = `[bad column name]`
var substitution = "[$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}