use strict;
my $str = '[bad column name]';
my $regex = qr/\[((\w+)\s?)*\]/p;
my $subst = '[$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";