#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\d+\]"
Local $sString = "некий текст[36465464]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)