import re
regex = re.compile(r"\[\d+\]")
test_str = "некий текст[36465464]"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)