const regex = /\[\d+\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\d+\\]', '')
const str = `некий текст[36465464]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);