$re = '/\[\d+\]/';
$str = 'некий текст[36465464]';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;