using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/www\.youtube\.com\/watch\?v=([a-zA-Z0-9]+)";
string input = @"https://www.youtube.com/watch?v=TF3KeTOL9Ac";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}