re = /https:\/\/www\.youtube\.com\/watch\?v=([a-zA-Z0-9]+)/
str = 'https://www.youtube.com/watch?v=TF3KeTOL9Ac'
# Print the match result
str.match(re) do |match|
puts match.to_s
end