const regex = /https:\/\/www\.youtube\.com\/watch\?v=([a-zA-Z0-9]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/www\\.youtube\\.com\\\/watch\\?v=([a-zA-Z0-9]+)', '')
const str = `https://www.youtube.com/watch?v=TF3KeTOL9Ac`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}