$re = '/https:\/\/www\.youtube\.com\/watch\?v=([a-zA-Z0-9]+)/';
$str = 'https://www.youtube.com/watch?v=TF3KeTOL9Ac';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);