# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?-.*?)-.*$/\1/gm;t' <<< "60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4"