// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?-.*?)-.*$").unwrap();
let string = "60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}