#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?-.*?)-.*$"
Local $sString = "60166213" & @CRLF & _
"" & @CRLF & _
"60173866-4533" & @CRLF & _
"" & @CRLF & _
"60167323-9439-1259801" & @CRLF & _
"" & @CRLF & _
"NL170-2683-1262201" & @CRLF & _
"" & @CRLF & _
"60174710-1-A12-4"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)