using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?[0-9]{1,9}(?:\.[0-9]{1,3})?$";
string input = @"1
12
123
1234
12345
123456789
1234567890
-1
-12
-123456789
-1234567890
1.1
1.12
1.123
1.1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}