package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?[0-9]{1,9}(?:\.[0-9]{1,3})?$`)
var str = `1
12
123
1234
12345
123456789
1234567890
-1
-12
-123456789
-1234567890
1.1
1.12
1.123
1.1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}