// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?[0-9]{1,9}(?:\.[0-9]{1,3})?$").unwrap();
let string = "1
12
123
1234
12345
123456789
1234567890
-1
-12
-123456789
-1234567890
1.1
1.12
1.123
1.1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}