import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?[0-9]{1,9}(?:\\.[0-9]{1,3})?$";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "123456789\n"
+ "1234567890\n"
+ "-1\n"
+ "-12\n"
+ "-123456789\n"
+ "-1234567890\n"
+ "1.1\n"
+ "1.12\n"
+ "1.123\n"
+ "1.1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}