$re = '/^-?[0-9]{1,9}(?:\.[0-9]{1,3})?$/m';
$str = '1
12
123
1234
12345
123456789
1234567890
-1
-12
-123456789
-1234567890
1.1
1.12
1.123
1.1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);