# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\w.-]//g;t' <<< "A\'skljdsg\\\sk//dgj@@@////#``flkl_dfd-_-sfsfs-fk kgj.docx"