package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w.-]`)
var str = `A\'skljdsg\\\sk//dgj@@@////#\`\`flkl_dfd-_-sfsfs-fk kgj.docx`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}