re = /[^\w.-]/
str = 'A\\\'skljdsg\\\\\\sk//dgj@@@////#``flkl_dfd-_-sfsfs-fk kgj.docx'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result